От авторов

Эта справочная система написана для редактора SourceViewer версии 2.30 (билд от 23.09.2003). Для других версий часть информации, приведённой в этом справочнике, может не соответствовать возможностям программы.

Команда разработчиков приложила значительные усилия, направленные как на повышение функциональности предлагаемого программного продукта, так и на повышение надежности его работы. Мы надеемся, что работа с новым редактором станет еще проще и комфортнее.

В редакторе реализованы новые технологии, не имеющие аналогов в мировой практике. Никогда прежде plain-text редактор не обладал такими возможностями. Любители редактирования с помощью мышки по достоинству оценят возможности перемещения текста при помощи технологии Drag&Drop как в пределах редактора, так и при взаимодействии с различными приложениями. Для тех, кто особоенно ценит свое время, предусмотрен значительный набор горячих клавиш.

Программа распространяется на условиях FreeWare при обязательном соблюдении авторских прав. Это означает, что Вы можете свободно использовать редактор, а так же растпространять его на некоммерческой основе при условях обеспечения целостности программы.

Несмотря на то, что данный радактор передается Вам на безвозмездной основе, команда разработчиков сочтет за честь получить денежное, материальное, натуральное, либо иное вознаграждение от любого частного лица как благодарность за проделанную работу.

Команда разработчиков SourceViewer

  • min@y™, minay-tm@mail.ru, minay-tm@narod.ru;

  • DiMan, somniator@land.ru;

  • Злобный ФСБшник, lifesucks@pisem.net.

Домашняя страничка программы: http://sourceviewer.narod.ru.

Общий почтовый ящик программы (для пожеланий, критики и баг-репортов): sourceviewer@narod.ru.

Рязань, 2003


Назначение программы

Так как я работаю программистом, то у меня в компе скопилось чудовищное количество исходников (в большинстве своём - на Delphi). Чтобы комфортно их просматривать с подсветкой синтаксиса, приходилось загружать громоздкую Delphi, что было довольно нецелесообразно. Поэтому у меня давно появилась мысль написать свой просмотрщик исходников, который бы быстро загружался, был удобным и т.д. Вот почему у программы такое название - SourceViewer (Source [англ.] - исходный текст, Viewer [англ.] - просмотрщик).

По мере создания программы я давал промежуточные бета-версии своим друзьям и знакомым, дабы поюзать да потестировать. Некоторым из них редактор понравился, в частности Злобный ФСБшник стал на нём творить HTML-документы, скрипты и пр., так как на подсветке одного Object Pascal я изначально останавливаться не стал.

Так как число бета-тестеров множилось, интенсивно стали находиться и исправляться всевозможные баги и глюки, а также вводиться новые проектные решения, приведшие в результате к финальной версии программы.


Лицензионное соглашение

Программа SourceViewer XP распространяется как freeware. Все авторские права на программу SourceViewer XP принадлежат авторам программы. Граждане стран бывшего СССР имеют право использовать данную версию программы SourceViewer XP в некоммерческих целях бесплатно.

Если условия данной лицензии не устраивают попадающих под ее действие лиц, они имеют право воспользоваться на общих основаниях лицензией, приведенной в файле License.txt. Для коммерческого использования программой SourceViewer XP необходимо получить письменное разрешение от авторов.

Авторы не гарантирует оперативной технической поддержки. Авторы оставляют за собой право отменить действие данной лицензии для любой из следующих версий программы SourceViewer XP.

Программа SourceViewer XP распространяется свободно, при условии того, что настоящий дистрибутив не изменен. Ни одно частное лицо или организация не может брать плату за распространение SourceViewer XP без письменного разрешения от авторов.

ПРОГРАММА SourceViewer XP ПОСТАВЛЯЕТСЯ ПО ПРИНЦИПУ "КАК ЕСТЬ" ("AS IS"). НИКАКИХ ГАРАНТИЙ НЕ ПРИЛАГАЕТСЯ И НЕ ПРЕДУСМАТРИВАЕТСЯ. ВЫ ИСПОЛЬЗУЕТЕ ЭТО ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НА СВОЙ РИСК. АВТОРЫ НЕ БУДЕТ ОТВЕЧАТЬ НИ ЗА КАКИЕ ПОТЕРИ ИЛИ ИСКАЖЕНИЯ ДАННЫХ, ЛЮБУЮ УПУЩЕННУЮ ВЫГОДУ В ПРОЦЕССЕ ИСПОЛЬЗОВАНИЯ ИЛИ НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ.

На коммерческое распространение программы, в частности, на публикацию на CD, необходимо согласие авторов. Применённые в программе алгоритмы также являются объектом авторских прав.

Вы можете свободно распространять настоящий дистрибутив программы в пределах планеты Земля и околоземного пространства. Но не советуем декомпилировать, дизассемблировать и т.п., т.к. это будет просто необоснованной тратой времени. Проще написать нам и спросить исходник. :-))

Установка и использование SourceViewer XP означает, что Вы понимаете положения настоящего лицензионного соглашения и согласны с ними.

Если почему-либо Вы не согласны ни с этим лицензионным соглашением, ни с соглашением, приведенным в файле License.txt, Вам необходимо удалить файлы дистрибутива SourceViewer XP с Ваших устройств хранения информации и прекратить использование программы SourceViewer XP.

З.Ы. На самом деле всё не так страшно. Это соглашение писал не я, а Somniator, а он его дёрнул с какой-то другой проги, как, впрочем, все и делают. :-)). Я тут децл заменил кое-что...


Вырезание, копирование, вставка, удаление

Работа с документами. Вырезание, копирование, вставка, удаление

В Windows есть такая штука, как буфер обмена. Он предназначен для обмена данными внутри программы и между программами. SourceViewer использует его для вырезания, копирования и вставки текстовых блоков в документы.

Чтобы вырезать выделенный текст, выберите соответствующий пункт меню в меню "Правка", либо во всплывающем меню редактора, или нажмите Ctrl+X (Shift+Del).

Чтобы скопировать выделенный текст, выберите соответствующий пункт меню в меню "Правка", либо во всплывающем меню редактора, или нажмите Ctrl+C (Ctrl+Ins).

Чтобы вставить выделенный текст в позицию курсора или вместо выделенного фрагмента текста, выберите соответствующий пункт меню в меню "Правка", либо во всплывающем меню редактора, или нажмите Ctrl+V (Shift+Ins).

Чтобы удалить выделенный текст без помещения его в буфер обмена, выберите соответствующий пункт меню в меню "Правка", либо во всплывающем меню редактора, или нажмите Del (Ctrl+Del).

Все эти команды дублируются кнопками панели "Правка".


Откаты и отмена откатов

Работа с документами. Откаты и отмена откатов

В каждом окне редактора предусмотрена очередь из 1024 последних операций пользователя. Если Вы что-то сделали не так, то последние действия всегда можно отменить с помощью пункта меню "Отмена" или комбинацией клавиш Ctrl+Z (Alt+BkSp).

Если после отката понадобится вернуть то, что отменили, Вам поможет пункт меню "Вернуть" или клавиши Ctrl+Alt+Z.

Все эти команды дублируются кнопками панели "Правка".


Редактирование мышью

Работа с документами. Редактирование мышью

В программе предусмотрена возможность перетаскивания и копирования текста мышью по технологии Drag&Drop.

Если нужно перетащить выделенный фрагмент, двигайте его в нужное место, удерживая левую кнопку мыши.

Чтобы скопировать выделенный фрагмент, делайте то же самое, одновременно удерживая клавишу Ctrl.

Чтобы просто выделить одно слово, дважды щёлкните на нём мышью.

Одиночное нажатие правой кнопки мыши в поле редактора откроет его контекстное меню, в котором доступны все опции редактирования.

Всплывающее меню редактора


Способы открытия и закрытия документов

Работа с документами. Способы открытия и закрытия документов

Вызвать диалог открытия файлов можно следующими способами:

  • выбрать пункт меню Файл --> Открыть;

  • нажать Ctrl+O;

  • если не открыто ни одного файла, дважды щёлкнуть на синем логотипе программы;

  • выбрать пункт меню Открыть контекстного меню вкладки.

Также открыть файл вы можете:

  • перетаскивать файл на редактор или логотип из проводника;

  • перетаскивать файл на редактор или логотип из истории открытия файлов;

  • перетаскивать файл или группу файлов на редактор или логотип прямо из проводника Windows (из папок);

  • перетаскивать файл или группу файлов на редактор или логотип из Windows Commander или Total Commander.

Имейте в виду, что в диалоге открытия файла можно выбрать сразу несколько файлов, выделив их мышью и нажав кнопку "Открыть".

Закрыть файл Вы можете следующими способами:

  • выбрать пункт меню Файл --> Закрыть;

  • нажать Ctrl+F4 или Ctrl+W;

  • выбрать пункт меню Закрыть контекстного меню вкладки;

  • выбрать пункт меню Закрыть контекстного меню редактора.

В главном и контекстных меню предусмотрены также пункты Закрыть всё и Закрыть всё, кроме этого.


Обновление документа

Работа с документами. Обновление документа

Если Вы хотите отменить все изменения, сделанные в документе, либо Вы редактируете документ в другой программе, а просматриваете в SourceViewer, то документ можно обновить из файла на диске, выбрав в меню команду "Обновить" или нажав клавишу F4.


Режимы редактора

Работа с документами. Режимы редактора

Редактор имеет режим вставки и режим замены. При переключении режимов форма курсора меняется. Переключение режимов осуществляется нажатием клавиши Ins или двойным щелчком мыши на панели, отображающей режим.


Поиск

Если текст довольно большой, иногда возникает потребность найти в нём отдельное слово или фразу. Нажмите Ctrl+F, либо выберите соответствующий пункт меню "Поиск" или контекстного меню редактора. Появится диалог задания параметров поиска.

Задайте строку, которую надо найти (шаблон), а также опции поиска и нажмите ОК или клавишу Enter.

Для поиска следующих вхождений введённой строки нажимайте клавишу F3 или соответствующие пункты меню.


Замена строк в тексте

Поиск. Замена строк в тексте

Для замены в тексте одной строки на другую предназначен диалог замены. Для его вызова Нажмите Ctrl+R, либо выберите соответствующий пункт меню "Поиск" или контекстного меню редактора.

Задайте строку, которую надо найти (шаблон), строку, на которую надо заменить, а также опции поиска и нажмите ОК или клавишу Enter, для замены первой найденной по шаблону строки или кнопку "Всё", если надо заменить все вхождения искомой строки.


Поиск в файлах

Поиск. Поиск в файлах

Если вы хотите узнать, в каких файлах находится заданный текст, вам поможет поиск в файлах. Выберите соответствующий пункт меню "Поиск". Появится диалог поиска в файлах.

Задайте искомую строку, опции поиска, кодировку текста и нажмите ОК или клавишу Enter. Дилог закроется и появится окно результатов поиска в файлах.

Из этого окна можно открыть выбранный файл двойным щелчком мыши. Найденная строка будет в верхней части редактора с этим файлом.


Навигация по закладкам

Поиск. Навигация по закладкам

Когда редактируемый текст имеет большой размер, целесообразно пользоваться закладками для навигации по нему. В каждом документе может существовать до 10 закладок.

Чтобы поставить закладку на строку с курсором, выберите соответствующий пункт меню "Правка --> Закладки" или нажмите Ctrl+Shift+<номер закладки>.

Для перехода к закладке выберите соответствующий пункт меню "Правка --> Перейти по закладке" или нажмите Ctrl+<номер закладки>.

В подменю "Правка --> Перейти по закладке" отображаются только закладки, существующие в данном окне редактора.


Выбор принтера, его настройка и печать

Печать. Выбор принтера, его настройка и печать

Чтобы просто отправить на печать открытый документ, выберите соответствующий пункт меню "Файл" или нажмите Ctrl+P. Появится диалог выбора принтера.

Выбрать нужный принтер (в том числе и сетевой) можно в этом же диалоге. Тут же можно задать и количество копий печатаемого документа.

Чтобы настроить выбранный принтер, нажмите в этом диалоге кнопку "Свойства" или перед печатью выберите пункт "Настройка принтера" в меню "Файл". Появится диалог настройки принтера.

Здесь вы можете задать различные параметры принтера, такие как размер бумаги, её ориентацию и т.д.


Печать выделенного текста

Печать. Печать выделенного текста

Иногда возникает необходимось печати не всего документа целиком, а его выделенной части или диапазона страниц.

Если перед вызовом диалога печати выделить часть текста, то опция "Выделенный фрагмент" в этом диалоге станет доступной (см. рисунок).


Предварительный просмотр и печать диапазона страниц

Печать. Предварительный просмотр и печать диапазона страниц

Для визуального представления результатов печати предназначен диалог предварительного просмотра.

Из этого диалога Вы можете узнать, сколько страниц содержит документ, визуально представить размеры полей и отступов текста, представить вид документа в различных масштабах (10 - 400)%.

В некоторых случаях бывает необходимо напечатать не все, а только диапазон страниц документа. Если вызвать диалог печати из окна предварительного просмотра (нажать соответствующую кнопку на панели инструментов), то опция "Страницы" в этом диалоге станет доступной (см. рисунок).


Настройка параметров страницы

Печать. Настройка параметров страницы

Для более гибкой настройки параметров печати предназначен диалог настройки параметров страницы. Сам по себе, он разбит на 3 страницы.

На 1-й странице Вы можете задать необходимые поля и отступы текста, ширину полосы переплёта, а также включить или отключить зеркальную печать, номера строк, подсветку синтаксиса и цвет при печати.

На второй странице диалога Вы можете определить размеры и отступы верхнего и нижнего колонтитулов.

И, наконец, на третьей странице Вам даётся возможность задать следующие параметры:

  • вывод текста верхнего и нижнего колонтитулов;

  • цвет текста и шрифт в различных позициях колонтитулов;

  • вывод линий и/или рамок, ограничивающих колонтитулы;

  • цвет этих линий и/или рамок;

  • вывод номеров страниц документа;

  • вывод количества страниц документа.

Колонтитул может содержать кроме текста следующие служебные слова, заменяемые программой при выводе на печать:

$TITLE$ | имя файла печатаемого документа
$PAGENUM$ | номер страницы
$PAGECOUNT$ | количество страниц
$DATE$ | дата печати
$TIME$ | время печати

Результаты установок диалога "Параметры страницы" затем можно увидеть в диалоге "Предварительный просмотр":

При необходимости диалог "Параметры страницы" можно вызвать прямо из диалога "Предварительный просмотр", нажав соответствующую кнопку панели инструментов диалога.


Типы подсветки, поддерживаемые редактором

Подсветка синтаксиса. Типы подсветки, поддерживаемые редактором

Редактор поддерживает подсветку синтаксиса для следующих типов файлов:

Тип файлов | Расширения
программы на Pascal/Delphi | *.pas;*.dpr;*.dpk;*.inc
программы на С/С++ | *.c,*.cpp,*.h,*.hpp
файлы форм Delphi/C++Builder | *.dfm;*.xfm
программы на Visual Basic/VBS | *.bas
программы на x86-ассемблере | *.asm
программы на x51-ассемблере | *.asm;*.apj
bat/cmd-файлы | *.bat;*.cmd
файлы PHP | *.php,*.php3,*.phtml
ini, inf-файлы настроек | *.ini,*.inf
msg-файлы | *.msg
html web-документы | *.htm,*.html,*.shtml
java, javascript-программы | *.java;*.js
xml/manifest-документы | *.xml,*.xsd,*.xsl,*.xslt,*.dtd,*.manifest
файлы Perl | *.pl,*.pm,*.cgi
файлы css | *.css
файлы sql | *.sql
программы на языке Basis (в интернет-релизе не поддерживается) | *.b

Тип подсветки синтаксиса определяется автоматически по расширению файла при его открытии или сохранении вновь созданного документа. Если файл имеет расширение, которое в таблице отсутствует, подсветка ему не назначается (например, текстовые документы *.txt).


Выбор подсветки для документа

Подсветка синтаксиса. Выбор подсветки для документа

Иногда бывает необходимо назначить тип подсветки вручную. Например, в текстовом документе содержится фрагмент программы на C++, а расширение файла - *.txt, так что тип подсветки программой не назначается автоматически.

Для этих целей в программе предусмотрен выпадающий список типов подсветки синтаксиса. Просто выберите в нём нужный тип щелчком мыши.


Настройка подсветки

Подсветка синтаксиса. Настройка подсветки

Для задания цвета и стиля шрифта конкретных типов лексем каждого типа подсветки предназначен диалог "Подсветка синтаксиса".

Внимание! Изменения вступают в силу не по нажатию кнопки ОК, а сразу же в процессе изменения!

Ниже приводятся примеры видов редактора с подсветкой синтаксиса для различных языков программирования:

Object Pascal

C/C++

HTML

XML


Типы кодировок, поддерживаемые редактором

Кодировка символов. Типы кодировок, поддерживаемые редактором

Для хранения символов кириллицы используется несколько кодировок. Ниже приведен перечень поддерживаемых кодировок с кратким описанием каждой.

  1. CP-1251. Используется в ОС Windows, вследствие чего и получила широкое распространение.

  2. CP-866. Кодировка, используемая в ОС DOS, в месте с которой уходит в прошлое. Однако эта кодировка до сих пор находит широкое распространение в сети FIDO.

  3. KOI8-R. Кодировка, используемая для пересылки почтовых сообщений. Сегодня является стандартом de-facto в электронной почте, а так же является основной кодировкой большинства Unix-систем.

  4. ISO 8859-5. Кодировка, стандартизованная ISO. Широкого распространения не получила, и используется лишь в некоторых версиях Unix, а так же в узкоспециализированных промышленных системах.


Выбор кодировки

Кодировка символов. Выбор кодировки

Кодировку символов можно выбрать в меню Вид --> Кодировка символов или в выпадающем меню панели "Кодировка". При смене кодировка CP-1251 на любую другую, открытый файл сразу же отображается в соответствующей кодировке. Если же установлена кодировка, отличная от CP-1251, при ее смене файл необходимо открыть снова (при этом выводится соответствующее предупреждение), т.к. файлы загружаются в память только в кодировке CP-1251, а потом переводятся и этот перевод необратим.


Автораспознавание кодировки

Кодировка символов. Автораспознавание кодировки

При открытии файла, программа пытается определить используемую кодировку автоматически, если включена соответствующая опция. Как правило такое определение происходит корректно, и вмешательство пользователя не требуется.

Автораспознавание кодировки можно отключить. Для этого в пункте меню Вид --> Кодировка символов --> Автораспознавание необходимо снять соответствующую галочку.

Алгоритм распознавания вероятностный и редко когда, но всё же делает ошибки, так что поосторожнее с ним обращайтесь.


Для чего нужен экспорт?

Экспорт текста с подсветкой. Для чего нужен экспорт?

При документации, например, программного обеспечения необходимо представлять текст программы. Такой текст будет намного более читабельным, если будет с подсветкой синтаксиса. Поэтому в программу включена эта, такая нужная, возможность.

Экспорт возможен в форматы RTF (MSWord) или HTML.

Экспорт текста без подсветки невозможен, вместо этого следует пользоваться прямым копированием через буфер обмена.


Экспорт в RTF-формат

Экспорт текста с подсветкой. Экспорт в RTF-формат

Существуют 2 типа экспорта в формат RTF: прямо в файл или в буфер обмена.

Для экспорта в файл сделайте следующее:

  1. Выделите нужны блок текста (или всё).

  2. Выберите "Экспорт в RTF-формат" в меню "Экспорт" или нажмите Ctrl+D.

  3. Появится диалог сохранения файла, введите его имя.

  4. Нажмите ОК.

Если в настройках программы установлен флаг "Открывать экспортированные файлы", то помимо создания файла RTF откроется приложение, установленное по умолчанию для открытия файлов этого типа, например, Microsoft Word.

Второй тип экспорта - через буфер обмена. Выделенный фрагмент преобразуется в RTF-код и помещается в буфер, после чего вы можете его вручную вставить в любой RTF-редактор. Просто выделите текст и выберите "Экспорт в буфер обмена в RTF-формате" в меню "Экспорт" или нажмите Ctrl+Alt+D.


Экспорт в HTML-формат

Экспорт текста с подсветкой. Экспорт в HTML-формат

Существуют 2 типа экспорта в формат HTML: прямо в файл или в буфер обмена.

Для экспорта в файл сделайте следующее:

  1. Выделите нужны блок текста (или всё).

  2. Выберите "Экспорт в HTML-формат" в меню "Экспорт" или нажмите Ctrl+H.

  3. Появится диалог сохранения файла, введите его имя.

  4. Нажмите ОК.

Если в настройках программы установлен флаг "Открывать экспортированные файлы", то помимо создания файла HTML откроется приложение, установленное по умолчанию для открытия файлов этого типа, например, Microsoft Internet Explorer.

Второй тип экспорта - через буфер обмена. Выделенный фрагмент преобразуется в HTML-код и помещается в буфер, после чего вы можете его вручную вставить в любой HTML-редактор. Просто выделите текст и выберите "Экспорт в буфер обмена в HTML-формате" в меню "Экспорт" или нажмите Ctrl+Alt+H.


Зачем это нужно?

Открытие документов другими программами. Зачем это нужно?

Допустим, Вы редактируете web-страницу. Чтобы посмотреть, что получается, предназначена данная возможность программы SourceViewer.


Ассоциативное выполнение

Открытие документов другими программами. Ассоциативное выполнение

Ассоциативное выполнение - ни что иное, как открытие редактируемого файла ассоциированной с его типом программой. Например, для файлов *.pas - это Delphi, для *.cpp - C++Builder, *.htm - Internet Explorer, *.rtf - Microsoft Word и т.д.

Чтобы просмотреть (отредактировать) открытый в SourceViewer файл ассоциированной программой, следует выбрать пункт "Ассоциативное выполнение" в меню "Запуск" или нажать клавишу F5.


Выбор программ для открытия документов

Открытие документов другими программами. Выбор программ для открытия документов

Открывать из SourceViewer редактируемые документы можно не только ассоциированными программами (см. пункт "Ассоциативное выполнение"). Пользователь может сам задать список этих программ. При этом образуются и сохраняются соответствующие пункты меню "Запуск". Первые 3 программы в этом списке будут иметь соответствующие кнопки на панели инструментов "Запуск". Четвёртая кнопка - ассоциативное выполнение.

Формирование списка программ для запуска осуществляется с помощью соответствующего диалога. Выберите пункт "Программы для запуска..." меню "Запуск". Появится диалог выбора.

Добавьте нужные программы с помощью кнопки "Добавить". Менять порядок расположения программ можно перетаскиванием мышью. После нажатия ОК меню "Запуск" будет выглядеть примерно так:

Горячие клавиши:

  • Открыть в 1-й программе: Ctrl+F5.

  • Открыть во 2-й программе: Shift+F5.

  • Открыть в 3-й программе: Alt+F5.


Что такое автозамена?

Автозамены текста. Что такое автозамена?

Допустим, при написании текста Вы часто пользуетесь одним и тем же выражением, символом, группой символов. В программе SourceViewer предусмотрена автоматизация ввода таких вещей.

Например, если Вы редактируете текст на C++ и разделяете блоки текста комментарием вида:

//--------------------------------------------------------

то разумно было бы не копировать везде этот комментарий и уж, тем более, не набирать его с клавиатуры, а создать один раз для него ключ автозамены и всегда им пользоваться. Как это сделать, объясню на примере.


Добавление, изменение, удаление ключей автозамен

Автозамены текста. Добавление, изменение, удаление ключей автозамен

Выберите пункт "Автозамена" меню "Конфигурация". Появится диалог задания автозамен.

Пусть надо чтобы символы "//-" заменялись на комментарий, описанный выше. Создадим ключ. Для создания ключа нажмите кнопку "Добавить". Появится ещё один диалог.

Наберите ключ и его описание (и то и другое, можно по-русски), нажмите ОК. Затем в диалоге "Автозамена", открытом ранее, в поле редактирования наберите комментарий нужной длины, нажмите ОК. Всё, ключ создан и запомнен в файле конфигурации. Имейте в виду, что автозамена может быть и многострочной.

Для замены ключа в тексте наберите //- и нажмите Ctrl+J. Ключ заменится на нужную строку комментария.

Для изменения и удаления ключей автозамен в диалоге "Автозамена" предусмотрены соответствующие кнопки.


Работа с выпадающим списком автозамен

Автозамены текста. Работа с выпадающим списком автозамен

Чтобы воспользоваться автозаменой, есть ещё один способ - выпадяющий список, в котором отображаются все ключи и описания автозамен. В окне редактора нажмите Alt+J. Появится окно со списком.

Выберите нужный ключ и нажмите Enter или дважды щёлкните на нём мышью.


Работа с проводником

Проводник и история. Работа с проводником

Проводник позволяет легко выбирать файлы для открытия минуя соответствующий диалог. Работа с ним не представляет никакой сложности. Достаточно выбрать нужный файл и дважды щёлкнуть на нём мышью или перетащить в поле редактора или логотипа.

Кроме того интнграция позволяет пользоваться системым меню прямо в окне проводника (правая клавиша мыши), как позволяет работать с файлами проводник Windows, т.е. создавать, удалять, перемещать, копировать, сжимать в архивы и т.д.

Вид проводника с системным меню.


Работа с историей

Проводник и история. Работа с историей

В историю заносятся имена и пути открываемых программой файлов. По умолчанию предел её заполнения - 100 файлов, более старые ссылки удаляются. Этот предел можно изменить в настройках программы (максимум - 500).

Работа с историей также крайне проста. Чтобы открыть файл из истории, достаточно выбрать нужный файл и дважды щёлкнуть на нём мышью или перетащить в поле редактора или логотипа.

Для работы с историей предназначена группа команд "История" главного меню, а также всплывающего меню окна истории. Как они работают, объяснять, я думаю, не нужно.


Снимки групп

Эта возможность несколько напоминает проекты. Она позволяет отрывать сразу группу файлов одним кликом мыши. Снимок - это отдельный файл, где хранятся полные имена файлов, которые нужно открывать.

Чтобы создать снимок требуемой группы файлов, откройте эти файлы, затем нажмите <Alt+C>, соответствующий пункт меню "История" или пункт всплывающего меню поля снимков групп (см. рисунок).

Появится окно запроса, где Вы укажете имя группы. Можно задать имя существующей группы.

Нажмите ОК. Имя снимка занесено в список снимков.

Чтобы открыть файлы снимка, кликните дважды на его имени в списке. Все файлы снимка загрузятся редактором.


Интерфейс пользователя

Настройка программы. Интерфейс пользователя

Описание опций страницы:

  • Отображать подсказки - показ хинтов при наведении курсора мыши на кнопки.

  • Отображать уведомления - показ уведомлений о некоторых событиях (см. рисунок). Может тормозить на маломощных и сильно загруженных компах.

  • Открывать экспортированные файлы - см. пункты "Экспорт в RTF-формат" и "Экспорт в HTML-формат".

  • Показывать горизонтальный скроллер - показ/скрытие горизонтальной полосы прокрутки редакторов.

  • Показывать полосу закладок - показ/скрытие поля отображения закладок и номеров строк редакторов.

  • Граница в XXX символов - отображение полосы для обозначения длины строк в XXX символов (удобно для редактирования текста, который затем будет использоваться под DOS в текстовом режиме 80x25 символов).

  • Расположение вкладок - способ расположения вкладок относительно редакторов.

  • Вид вкладок - вкладки, кнопки или плоские кнопки (см. рисунок).


Цвета

Настройка программы. Цвета

Описание опций страницы:

  • Цвет фона - цвет фона редакторов.

  • Полоса закладок - цвет области отображения закладок и номеров строк.

  • Граница - цвет границы в XXX символов.

  • Использовать системные цвета - использование цветов Windows.

  • Только для Windows 2000/XP/2003 etc. Позволяет задать определённый процент прозрачности окна программы, в результате чего будет видно окна, находящиеся под ними. Удобно, например, при наборе серийных номеров в режиме "Поверх всех окон". Не рекомендуем использовать на медленных компах, т.к. тормоза с перерисовкой страшные, однако надеемся, что данная опция иногда может быть полезна. При включении этой опции и применении настроек внизу главного окна появится слайдер, с помощью которого можно будет задать процент прозрачности. Однако имейте в виду, что он сохранится в настройках и восстановится при следующем запуске программы, но если он был меньше 50%, то автоматически станет равен 50% (это чтобы у вас SourceViewer совсем не пропал :-)).


Интеграция

Настройка программы. Интеграция

  • Влезть в контекстное меню - если флажок установлен, то в контекстном меню проводника Windows для файлов незарегистрированных типов присутствует пункт меню "Открыть в SourceViewer".

  • Разворачивать из трея по... - горячая клавиша развёртывания программы из минимизированного состояния.

  • Предупреждать о размере файла свыше XXX МБ - при открытии файлов размером больше XXX выводится соответствующее предупреждение.

  • Открывать файлы, открытые при выходе - если этот флажок установлен, то в случае, если при выходе из программы были открыты файлы, их имена запоминаются, и эти файлы открываются при следующем запуске программы.

  • Помнить и восстанавливать позицию в закрываемых файлах - если этот флажок установлен, то при открытии файла позиция его верхней строки в редакторе восстанавливается, если она была запомнена.

  • Отображать поле предпросмотра в диалогах открытия и сохранения - если включено, то при открытии/сохранении будет возможно просмотреть содержимое некоторых (пока не всех) файлов в текущей папке диалога.

  • Предел заполнения - максимум файлов, запоминаемых в истории (1-500).

  • Автосохранение. Интервал: X минут - если активно, то через каждые X минут все открытые файлы будут сохраняться.


Редактор

Настройка программы. Редактор

  • Выделение колонки с <Alt> - при нажатой клавише Alt выделяется прямоугольный фрагмент текста (см. рисунок).

  • Перемотка на одну строку меньше - при перелистывании страниц вверх последняя строка предыдущей страницы становится первой, при перемотке вверх - наоборот.

  • Курсор за последним символом строки - возможность свободного ввода текста.

  • Перемотка после конца файла - перемотка на 1 страницу больше (без возможности редактирования текста за концом файла).

  • Подсказка с номером строки при перемотке мышью - см. рисунок.

  • Табуляция по словам предыдущих слов - удобное позиционирование курсора по нажатию клавиши Tab.

  • Удаление по словам предыдущих слов - то же самое, только с удалением слов по клавише Del.

  • Регулирование отступа по <Tab> и <Shift>+<Tab> - заданияе отступа для блока. Если отключено, то отступ регулируется по Ctrl+Shift+I/U.

  • Преобразование символов табуляции в пробелы - символы табуляции (ASCII #9) заменяются на пробелы при сохранении.

  • Удалять завершающие пробелы в строках - удаление завершающих пробелов в строках документа при сохранении.

  • Перетаскивание текста мышью - возможность редактирования мышью по Drag&Drop.

  • Перемотка в пол-страницы - перелистывание по половине страницы при нажатии PgUp/PgDown.

  • Групповой откат - объединение операций с текстом в группы и откат/отмена отката целыми группами.

  • Отображать спецсимволы - см. рисунок.

  • Автоотступ - позиционирование курсора по началу предыдущей строки при переходе на новую строку по нажатию Enter.


Проводник

Для ускорения загрузки программы теперь возможно задание корневой папки проводника. Раньше корнем всегда была папка "Мой компьютер", и проводник при создании главного окна сканировал носители информации, подключённые к компьютеру (жёсткие диски, дисководы, CD-приводы). Это занимало очень много времени. Теперь Вы можете задать в качестве корня любую папку, включая некоторые системные.


Автонумерация строк

Настройка программы. Автонумерация строк

  • Клавиша - выбор клавиши перехода на следующую строку с автовставкой номера строки.

  • Начать с: X - с какого номера начинать нумерацию, если в строках, расположенных выше предыдущий номер не найден.

  • Шаг - инкремент номера.

  • Дополнять слева - символы, которыми номер будет дополняться слева до длины X символов.

  • Вставлять пробелы (перед- и за номером) - количество пробелов, которыми номер будет отделяться от начала строки и от символов, последующих после вывода номера.


Работа с файлами

Горячие клавиши. Работа с файлами

Действие | Горячие клавиши
Создать новый файл | Ctrl+N
Открыть файл(ы) | Ctrl+O
Сохранить текущий файл | Ctrl+S, F2
Сохранить все несохранённые файлы | Ctrl+Alt+S
Обновить файл с диска | F4
Закрыть текущий файл | Ctrl+F4, Ctrl+W
Печать (вывод диалога) | Ctrl+P


Редактирование

Горячие клавиши. Редактирование

Действие | Горячие клавиши
Копировать выделенный текст | Ctrl+C, Ctrl+Ins
Вырезать выделенный текст | Ctrl+X, Shift+Del
Вставить текст из буфера обмена | Ctrl+V, Shift+Ins
Удалить выделенный текст | Del, Ctrl+Del
Отменить предыдушую операцию (группу операций) | Ctrl+Z, Alt+BkSp
Вернуть отменённую операцию (группу операций) | Ctrl+Alt+Z
Выделение прямоугольных блоков | Alt+левая кнопка мыши
Выделить весь текст | Ctrl+A
Прокрутка с курсором | Up/Down
Прокрутка без курсора | Ctrl+Up/Ctrl+Down
Выделение по вертикали | Shift+Up/Shift+Down
Выделение по горизонтали | Shift+Left/Shift+Right
Переход к следующему/предыдущему слову | Ctrl+Left/Ctrl+Right
Выделить следующее/предыдущее слово | Ctrl+Shift+Left/Ctrl+Shift+Right
Перемотка на страницу вверх/вниз | PgUp/PgDn
Выделение страницы вверх/вниз | Shift+PgUp/Shift+PgDn
Курсор в первую/последнюю строку страницы | Ctrl+PgUp/Ctrl+PgDn
Курсор в начало/конец строки | Home/End
Выделить от курсора до начала/конца | Shift+Home/Shift+End
Курсор в начало/конец документа | Ctrl+Home/Ctrl+End
Выделить от курсора до начала/конца документа | Ctrl+Shift+Home/Ctrl+Shift+End
Переключение между режимами вставки/замены | Ins
Удалить символ перед курсором | BkSp
Удалить символ за курсором | Del
Удалить слово перед курсором | Ctrl+BkSp
Увеличить/уменьшить отступ выделенного блока | Ctrl+Shift+I/Ctrl+Shift+U
Удалить строку | Ctrl+Y
Удалить символы от курсора до конца строки | Ctrl+Shift+Y
Поставить/снять/переместить закладку | Ctrl+Shift+[0..9]
Перейти по закладке | Ctrl+[0..9]
Табуляция | Tab
Поиск открывающей скобки для скобки за курсором | Ctrl+Shift+B


Поиск

Горячие клавиши. Поиск

Действие | Горячие клавиши
Найти строку в тексте | Ctrl+F
Найти далее | F3
Заменить строку в тексте | Ctrl+R
Поиск строки в файлах | Ctrl+Alt+F


Вид

Горячие клавиши. Вид

Действие | Горячие клавиши
Показать/скрыть проводник | Ctrl+E
Показать/скрыть историю открытия файлов | Ctrl+B
Расположить окно программы поверх/неповерх всех окон | Ctrl+T
Включить/отключить автораспознавание кодировки символов | Alt+R


Экспорт

Горячие клавиши. Экспорт

Действие | Горячие клавиши
Экспорт текста с подсветкой в RTF-документ | Ctrl+D
Экспорт текста с подсветкой в HTML-документ | Ctrl+H
Экспорт текста с подсветкой в RTF-формате в буфер обмена | Ctrl+Alt+D
Экспорт текста с подсветкой в HTML-формате в буфер обмена | Ctrl+Alt+H


Проводник, история, снимки групп

Действие | Горячие клавиши
Показать/скрыть проводник | Ctrl+E
Показать/скрыть историю открытия файлов | Ctrl+B
Создать снимок открытых файлов | Alt+C
Загрузить снимок | Alt+O


Конфигурация

Горячие клавиши. Конфигурация

Действие | Горячие клавиши
Показать/скрыть таблицу спецсимволов | F6
Показать скрыть номера строк | Ctrl+L
Включить/отключить перенос строк | Alt+W
Включить/отключить автонумерацию строк в тексте | Alt+A
Вызов окна "Параметры" | Alt+P


Работа с WEB-страницами

Действие | Горячие клавиши
Вставить гиперссылку | Ctrl+U
Вставить изображение | Ctrl+I
Вставить цвет | Ctrl+M


Открытие файлов другими программами

Горячие клавиши. Открытие файлов другими программами

Действие | Горячие клавиши
Ассоциативное выполнение текущего файла | F5
Выполнение файла в программе 1 | Ctrl+F5
Выполнение файла в программе 2 | Shift+F5
Выполнение файла в программе 3 | Alt+F5


Справочная система

Горячие клавиши. Справочная система

Действие | Горячие клавиши
Вызов справки | F1


Разное

Горячие клавиши. Разное

Действие | Горячие клавиши
Выход из программы | Alt+F4, Alt+X, F10
Свернуть программу в трей | Esc
Развернуть программу из трея | Настраивается пользователем


Калькулятор

В программу включён простенький калькулятор для выполнения быстрых расчётов. Вызывается клавишей F7.


Бастрое закомментаривание

Если нужно быстро закомментарить выделенный текст, нажмите <Ctrl+[>.

Пока эта функция поддерживается для файлов с подсветкой Pascal, Delphi/C++Biulder form, C++, PHP, CSS, HTML, XML.


Пробная страница для экспорта

Заголовок

unit minUtils;

interface

function GetIOResultError(const ErrorCode:Integer;const FileName:string):string;

implementation

{ Получение строки с ошибкой функции IOResult.}

function GetIOResultError(const ErrorCode:Integer;const FileName:string):string;

var

 FN:string;

 Result: string;

begin

 if FileName<>''

  then FN:=' '+FileName

  else FN:='';

 case ErrorCode of

  0   : Result:='';

  2   : Result:='File'+FN+' not found.';

  3   : Result:='Wrong file name'+FN+'.';

  4   : Result:='Too many open files.';

  5   : Result:='Access to a file' +FN + ' is closed.';

  100 : Result:='The end of a file is achieved'+FN+'.';

  101 : Result:='Disc full.';

  102 : Result:='The file variable is not assigned to a physical file'+FN+'.';

  103 : Result:='Attempt of operation with closed file'+FN+'.';

  104 : Result:='The file'+FN +' is not open for input.';

  105 : Result:='The file'+FN +' is not open for output';

  106 : Result:='Mistake of input or incorrect format of number.';

  else  Result:='IO error';

 end;{case Error of}

 GetIOResultError:=Result;

end;

end.

Конец документа.